Hardware and Software Selection
 


Hardware Selection Criteria

  • Hardware must support current software as well as software planned for procurement over the next planning interval [year, 18 months, three years]
  • Hardware must be compatible with existing or planned networks
  • Hardware must be upgradeable and expandable to meet the needs of the next planning interval
  • Hardware warranties must be of an appropriate length
  • Hardware maintenance must be performed by [local/remote vendor, in-house personnel]
  • Whenever feasible, hardware standards will dictate procurement of like brands and configurations to simplify installation and support
  • Routine assessments of installed infrastructure will feed an upgrade/replace decision process

Software Selection Criteria

  • Software must be compatible with current and future hardware over the next planning interval
  • Software maintenance and warranties must be of appropriate length and cost
  • Sotware help desk must be maintained by [vendor, third party, in-house personnel]
  • Software must be standardized throughout the business to improve purchasing power, simplify training, and facilitate support
  • Software must comply with current standards set by technology leadership
  • Software must support and enhance business goals

In addition to these hardware and software selection criteria, StratVantage will evaluate the proposed vendors on several criteria, including:

Stability — Vendor's attributes such as length of operations, size of customer base, size of income and revenue, company size, leadership, stock history and more can affect a technology purchasing decision

Proven Track Record — A vendor's experience not only in the broader market but in your business' specific industry can be key

Business Model Fit — If the vendor is offering, for example, software as a service, but your business isn't always Internet-connected, this business model mismatch could rule out the vendor

Mature Technology — You want to see continuity in the vendor's offerings. If the vendor has been through a series of acquisitions and is just now integrating new technology with an old line of business, you may want to obtain assurances on the longevity of the vendor's solution.

Service Level Agreements Unfortunately, most vendor Service Level Agreements (SLAs) aren't worth the paper they are printed on. We'll help you understand the vendor's SLA and negotiate a service level partnership instead.


An example hardware and software need for Oracle products -

Hardware and Software Requirements

This chapter describes the hardware and software requirements of Oracle Communications Data Model:

Before you install Oracle Communications Data Model, you must verify that all hardware and software requirements are met.

Supported Platforms

Oracle Communications Data Model 11g Release 2 (11.2) is supported on the following platforms. For each platform, the given operating system version or later versions are required:

  • Linux x86

    • Oracle Enterprise Linux 4 Update 7

    • Oracle Enterprise Linux 5 Update 2

    • Red Hat Enterprise Linux 4 Update 7

    • Red Hat Enterprise Linux 5 Update 2

  • Linux x86-64

    • Oracle Enterprise Linux 4 Update 7

    • Oracle Enterprise Linux 5 Update 2

    • Red Hat Enterprise Linux 4 Update 7

    • Red Hat Enterprise Linux 5 Update 2

  • Solaris SPARC (64-bit)

    • Solaris 10 U6 (5.10-2008.10)

  • AIX 5L Based Systems (64-bit)

    • AIX 5L V5.3 TL 09 SP1 ("5300-09-01"), 64 bit kernel

    • AIX 6.1 TL 02 SP1 ("6100-02-01"), 64-bit kernel

    Note:

    There are special considerations when installing Oracle Communications Data Model on AIX, see "AIX Platform: Changing the Database Parameter",
  • HP-UX Itanium

    • HP-UX 11i V3 patch Bundle Sep/ 2008 (B.11.31.0809.326a) or higher

Hardware Requirements

The Oracle Database installation guide for your platform includes procedures for checking that your installation meets the hardware and operating system requirements for Oracle Database.

Additionally, for a complete installation of Oracle Communications Data Model, the minimum hardware requirement is disk space of at least 10 GB.

Software Requirements

The minimum software requirements for Oracle Communications Data Model are as follows:

Note:

The recommended patches and software versions are accurate as of product release. For latest recommendations for database and Oracle OLAP for supported platforms, see https://www.oracle.com/technology/products/bi/olap/collateral/olap_certification.html.

Oracle Database Requirements

Oracle Communications Data Model requires Oracle Database 11g Release 2 Enterprise Edition.

Tip:

When you install the Database ensure that the database character set is UFT8 to support multi-language installations since Oracle Communications Data Model permits the installation of support for English and one other language.

Installation of the Oracle Communications Data Model component requires the following options to the Database:

  • Oracle Partitioning

  • Oracle Online Analytical Processing (OLAP)

  • Oracle Data Mining

Tip:To confirm that you have Oracle Data Mining and OLAP options installed, follow the instructions outlined in "Confirming that Oracle Data Mining and OLAP Options are Installed".

After you download and install the Database, upgrade to the latest patch. Patches are available from My Oracle Support (https://metalink.oracle.com).

Oracle Warehouse Builder

Oracle Communications Data Model requires the version of Oracle Warehouse Builder that comes as with Oracle Database 11g Release 2 Enterprise Edition. The ETL provided with Oracle Communications Data Model uses Oracle Warehouse Builder. For instructions on installing and configuring Oracle Warehouse Builder, see Oracle Warehouse Builder Installation and Administration Guide for Windows and Linux.

Tip:To confirm that you have Oracle Warehouse Builder installed, follow the instructions outlined in "Confirming that the OWBSYS Schema Exists".

 

Oracle Business Intelligence Suite Enterprise Edition

You must have the Oracle Business Intelligence Suite Enterprise Edition installed before you install the Oracle Communications Data Model sample reports. (Oracle Business Intelligence Suite Enterprise Edition is not required for the installation of the Oracle Communications Data Model component.)

Oracle Business Intelligence Suite Enterprise Edition 10.1.3.3 or higher can be downloaded from Oracle Technology Network at:

https://www.oracle.com/technology/software/products/ias/htdocs/101320bi.html

Installation instructions are included in the documentation.